FlowHeater Logo

FlowHeater Support Forum

simply more productive

Download the freeware version (10 Mb)

Up to 100,000 records can be processed with the freeware version!

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: always inserts, never updates excel to access

always inserts, never updates excel to access 5 years 1 month ago #2255

  • Paul D. Matthews
  • Paul D. Matthews's Avatar Topic Author
  • Offline
  • Posts: 2
The attached flowheater definition and SQL script will not update records in my Access 2010 database. The heater only inserts, never updates (for example, if one runs the same import twice, the records are appended, not updated.

THanks!

Attachment SPECTROFLOWHEATER.zip not found

Attachments:

Please Log in or Create an account to join the conversation.

Re:always inserts, never updates excel to access 5 years 1 month ago #2256

Hi Paul,

I don’t know what happened. For more analytics I’ve created one new FlowHeater definition including an Access 2010 database. Please run the Defintion "SPECTROFLOWHEATER-2.fhd" two times and check the result in the Access Database. After the first run there must be 100 insert and after the second run there must be 100 updates.

Then I’ve modified your FlowHeater Definition. I’ve just inserted a Clone Heater and activated the Debug output for the ID field. Please run the FlowHeater Defintion also two times on your database and check the result.

I guess in your Excel ID field are some wrong number who do not match the Access AutoID numbers in the table. In this case FlowHeater generates only insert statements.

Attachment Access_2010_Import_Update.zip not found

Attachments:

Please Log in or Create an account to join the conversation.

Best wishes
Robert Stark

Did this answer your question? We would be grateful if you provide a brief comment as feedback. It may also help others who may have encountered a similar problem.

Re:always inserts, never updates excel to access 5 years 1 month ago #2258

  • Paul D. Matthews
  • Paul D. Matthews's Avatar Topic Author
  • Offline
  • Posts: 2
Problem solved, thanks!!! I started a fresh table in Access to get the autonumber back in check...that was the problem.

Flowheater is great tool for my laboratory information management system.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.088 seconds